Broken links in comments

Product: Narrative

It happens that correct links, put in comments, become broken (saw that happening in posts too). What seems to happen is that "..." is inserted in the middle of link, but - occasionally - the original link is not kept. Instead, the shown link, with "..." is used, which is of course broken.

Original Post

Activity Stream

I'm not seeing an issue with broken links.  Yes, the appearance of the link is shortened for very long links, but if you click them, they work fine.

If you want to copy a link - instead of highlighting and copying the text, and  right click and choose copy link address, or whatever your browser terms it as.  On mobile (chrome is all I have) it's link press on the link and press copy link address.  Someone else will have to tell us how it's on on an iPhone. 

@David Dreezer, it occasionally happens. I've not found what triggers it.

Of course, I put the full link, in the comment, not the text, but sometimes the text still becomes a link (with the "...") but it's a broken link.

I've a clear example, but I can't put a link to a comment (oh, that's a suggestion...), so I can give you only the link of the story

https://www.narrative.org/post...-don-ts-on-narrative

and a screenshot of the comment

If I go in edit, the link is intact.

Attachments

Photos (1)
Vico Biscotti posted:

@David Dreezer, it occasionally happens. I've not found what triggers it.

Of course, I put the full link, in the comment, not the text, but sometimes the text still becomes a link (with the "...") but it's a broken link.

I've a clear example, but I can't put a link to a comment (oh, that's a suggestion...), so I can give you only the link of the story

https://www.narrative.org/post...-don-ts-on-narrative

and a screenshot of the comment

If I go in edit, the link is intact.

Every comment has a direct permalink.  Mouse over the date/time on the comment under the commentor's name.

This comment is https://www.narrative.org/post...nt=49310581546690363

David Dreezer posted:
Vico Biscotti posted:

@David Dreezer, it occasionally happens. I've not found what triggers it.

Of course, I put the full link, in the comment, not the text, but sometimes the text still becomes a link (with the "...") but it's a broken link.

I've a clear example, but I can't put a link to a comment (oh, that's a suggestion...), so I can give you only the link of the story

https://www.narrative.org/post...-don-ts-on-narrative

and a screenshot of the comment

If I go in edit, the link is intact.

Every comment has a direct permalink.  Mouse over the date/time on the comment under the commentor's name.

This comment is https://www.narrative.org/post...nt=49310581546690363

Oh! Didn't notice that... Great. Not that evident, but good to know.

Add Reply

Post
×
×
×
×