Can't access my account because of problems with Google Authenticator

Product: Narrative

The login asked for the code from Google Authenticator, but no code was accepted (while, of course, they were in the past).

I reinstalled Google Authenticator, but now the Narrative code is not there, and my Narrative login still ask for the Google Code.

So, I'm locked out.

Before trying to reset the password or something else, I'm asking.

Original Post

Activity Stream

Hi Vico,

When you set up the 2fa you were given a series of 10 emergency codes to save for use to retrieve your account if you lose your authenticator. You can use one of the 10 code emergency codes to log in with and then reset your authenticator. There is no way to retrieve your account without them.

Well, @David Dreezer, the issue splits in two. Half of it is still there.

I forgot to have the backup codes. My bad, and thanks for reminding me (a reminding message on invalid codes could help, in this case). I logged in again. But...

I deactivated the 2fa, in order to set it again with the authenticator (seems it's the only way to activate the authenticator, so you should always remember to keep one further backup code for this occurrence, else you can't deactivate the 2fa even if you're authenticated...). However, once Google authenticator scanned the barcode, Narrative asked for the ga code and... I got invalid code again, exactly as the situation that led to my remaining locked out. Now, I can't activate the 2fa (or so it seems to me).

And that's the problem all started from, independently from my forgetting the backup codes. I was always getting "invalid value", and I'm still getting it now, even having reinstalled google authenticator.

Attachments

Photos (1)

Hi Vico,

I've had the same issue once when the time on the old computer that I was testing with was off by a minute.

What I would do is log out completely from Narrative.  Close the browser. Give it a minute.  What we're trying to do is establish a new session.  Make sure that the time on the device that you are using is correct.  Log in again, then try to enable 2fa.   

I personally don't prefer the google authenticator. I like 1password or similar apps a lot better because you can synch most of them to dropbox, owncloud, or other cloud based storage device and if you lose, upgrade, or reset your phone you have not lost your authenticator.  Almost everyone that uses the google authenticator eventually runs into issues with it.  

Logging out/in doesn't solve, @David Dreezer.

Actually, there IS a slight difference between time on Android and time on desktop (Windows 10), but both of them are in their default config, so the thing is expected to work in THIS setup.

I not only reinstalled Google Authenticator but also manually asked for time sync in the options.

Also, I forgot to mention that before now I got the error in the past on Chrome on Android, on the same phone as the ga. However, I never use Narrative on the smartphone so I didn't pay much attention, but I remember to have tried more than once, without success. So, I just tried NOW, and... I get the same error of invalid code on Android, trying to set the 2fa.

It seems impossible to setup the 2fa, now, both from desktop and Android.

Add Reply

×
×
×
×